Jump to content
We've recently updated our Privacy Statement, available here. ×

SpotFire write back to Oracle db


Egor Kasprov

Recommended Posts

Colleagues,

Could you please asvise way of writing data from SF to Oracle.

I look through several solutions no one with Oracle example.

I like idea with creating Procedure and using INFO link connect inSF, but cant understand how such procedure should look like.

Could share your experience or instructions.

Thnak you,

Egor

Link to comment
Share on other sites

I have the same struggle !   I have done a lot of research and seen examples on YouTube but it was for SQL Server.  link: https://www.youtube.com/watchv=HroAtSE0VbU   It's actually pretty good and fun to watch!

 

I borrowed the idea and came close but STILL NO SUCCESS.   Long story short, everything from the video works with some adjustment for ORACLE.   The problem is when I tried to create the INFOLINK.   If you use pre or post as procedure type, it complains about not have result set columns because the result columns are grey out.

 

If you use "query" as procedure type which allows you to specify result columns, when try to save as infolink, the error message was "Failed to execute query: The query returned no result set (HRESULT: 80131500)".  

 

My stored procedure has an INSERT SQL followed by a SELECT SQL.  Just like the SQL Server example from YouTube link above.  

 

I tried to define a cursor in the parameter to return a result set but SPOTFIRE doesn't support the cursor datatype.

 

I tried a SELECT without a where clause and Spotfire complains the SQL returned too many rows.

 

I tried a SELECT which returns a single row and Spotfire complains; "Failed to execute query: The query returned no result set (HRESULT: 80131500)".  

 

For now.   I am stuck.   Maybe someone has done this in the past and can share some insight with all of us who are struggling with this simple thing !!

 

Cheers

Link to comment
Share on other sites

Paul, thank you for your comments.

 

Same story for me. I have tried same video you shared and for MS SQL it is works very fine.

 

Data is writing in Database from SF.

 

But seems in Oracle a bit different syntax, so procudery couldn't callback inserted values.

 

That is why asked for help there.

 

Also, there is a option make such functionality through Phyton scripting.

 

Is anybody tried such method Would be nice if you can share instructions.

 

Thank you

 

Egor

 

 

 

 

 

 

 

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...