Jump to content
We've recently updated our Privacy Statement, available here. ×

How to Create a Data Stream from Apache Kafka - SFDS 103 - Alternate Method


Krishna Chaitanya 4

Recommended Posts

Regardinghttps://community.spotfire.com/wiki/how-create-data-stream-apache-kafkar-sfds-103

Hi,

Fact is we have no setup for kafka broker running locally . so we would like to go with the "Another way" approach you suggested below.

-------

Another way would be to use StreamBase Studio and its LiveView Project Viewer and wizards to first create the LiveView data table you want, then add a LiveView Publisher with a data provider type of Apache Kafka, then edit in the properties and payload parsing into the generated provider sbapp.(Happy to guide you through that if all this is new to you.)

------------

step1- I have loaded a sample helo into stream base studio.

step2- Added LiveView Publisher with a data provider type of Apache Kafka

And I got the atatched error message when i done with the step2 . the below error is fixed by creating a Java folder src/main/java .

Error message "src/main/java does not exist" means that i need to add it to project.

In Studio, right-click on the root project folder and select "New > Source folder".

Then set the folder name to src/main/java2.

This folder should then appear in the Project Explorer.

At that point, right-click on src/main/java2 and select "Refactor > Rename".

Then rename it from 'java2' to just 'java'.

step3) Then edit in the properties and payload parsing into the generated provider sbapp

I need help on step3 and also the next steps that are required to make a connection to kerberized kafka broker. If any use case doc is available on this kindly provide.

Link to comment
Share on other sites

  • 1 month later...

Wow. I did not see this post until now. Many apologies.

I figure you've gotten past this by now, at least I hope so, as it's been two months.

That actually looks like a bug of some kind. I'd enter a Support Case. It would always help if you mentioned what version of TIBCO Streaming you were using, because I can't reproduce that.

I just tried this with TIBCO Streaming 10.5.0 and I didn't get the same error, but it did for some reason generate two ItemsSalesProvider.sbapps (one was named ItemsSalesProvider2.sbapp, that's the one the higher level KafkaPublisher.sbapp referenced). So, that was weird but it would work.

If by any chance you still want to discuss this after all this time, please comment here, though as I said this looks more like a Support issue than an Answer discussion.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...