Jump to content

Comas instead of dot exporting file from Tibco Spotfire Analyst to csv file.

Tatjana Kliosova

Recommended Posts

Till that time .csv file were opened like excel, and looks like excel table. Files exported from Tibco Analyst I see not like excel table, but like one row with data in each cell. I see a lot of data in one cell separated by coma. like this:

0,236544,tap,266 and so on

and want to see  like this (each meaning in separate column)

0 236544 tap 266
0 236545 tap 278
1 236546 tip 278

Link to comment
Share on other sites

Thank you for sending the file. I can see the problem with this file - each line is surrounded by quotation marks (") so it is being interpreted as being a long string instead of distinct columns. Please provide the exact steps you used to create this file by exporting it from Spotfire, as the quotation marks shouldn't be there.


That being said I did a quick test of exporting data from Spotfire and I encountered the same issue, even though my *.csv file did NOT have the quotation marks around each line. I Googled this issue and found a few resolutions.


1. In your Control Panel/Regional Settings, make sure your 'List separator' is set to a comma. Mine already was, so this didn't resolve anything for me, but if yours is set to something else try changing it to a comma. You may have to restart your machine to affect the change.

2. Change the encoding of the file. If you open the file in Notepad++ you can click on Encoding to change it to UTF-8, which should resolve the issue.

3. Add a line to the top of the file, so it looks like:




Hopefully one of these solutions will help resolve the issue, once your exported data doesn't include the quotation marks.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...