Jump to content
We've recently updated our Privacy Statement, available here. ×

Spotfire Client 10.0 cannot restore minimized popup dialogs/windows (causes SPF seem to be not responding)


Peter Tusnadi

Recommended Posts

Hi,

Our team faced a strange behavior in the Spotfire 10.0 desktop client (Under Windows 10 1803 and 1809 edition up to SPF 10.0 Hotfix3)

Our Spotfire desktop extensions can pop up modal dialogs that can be minimized. Theoretically when the user clicks the minimize button on any dialog, then the Spotfire and the dialog should minimize themselves together to the taskbar. But instead of this normal behavior the Spotfire does not minimize itself just tipically jumps into the background and only the dialog is minimized.

But when the user clicks on the taskbar icon of the dialog, the window cannot be restored to a normal size. (Only if the user opens the context menu of the dialog by "blindly" pressing the ALT+Space or right clicking on the taskbar miniature)

Because of this strange behavior users typically consider Spotfire as frozen (not responding) and kill the Spotfire process loosing their actual work.

This issue can be reproduced even with built-in minimizable (but non-modal) window like the Information Designer (no extension is need to be installed!). (See the attached video)

 

We tried to set the "owner" to the Spotfire Main Form in the Form.ShowDialog(owner) method, but it did not help.

We tried to update the operating System to the latest Win10 1809, but it did not help.

 

This problem sometimes disappears, and dialog windows are restored correctly for a short period of time, but half an hour later the problem comes back and no windows can be restored again. Although the clicked "restored" but invisible dialogs can not be seen on the screen they can recieve keyboard events: so if e.g. I press Alt+F4 the dialog will be closed (its taskbar icon of the dialog closes itself), and Spotfire returns to a normal usable state.

If anyone has idea what can be the root cause of this strange problem please share the info. Maybe this is a possible Spotfire 10.0 bug.

Thanks for the answer in advance.

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...