Jump to content
We've recently updated our Privacy Statement, available here. ×

Cannot connect to a PostgreSQL 11 database


Petko Ditchev

Recommended Posts

I'm trying to connect SpotFire to a PostgreSQL database (ver. 11) . I got the error message: "ERROR [42703] ERROR: column p.proisagg does not exist; Error while executing the query" . I tried versions 9.*, 10.* and 11.* of the ODBC driver, whith the same result. Tested the DB with other services and it works (DBeaver, pgAdmin4). As far as I could figure out removing proisagg was a recent backwards incompatible change in PostgreSQL 11. Reference mailing list discussion: https://www.postgresql.org/message-id/CAFj8pRD8y4CLmMq8zEcNsx8YW27s55yvS...

Any advice would be appreciated. i guess I could've missed something.

Link to comment
Share on other sites

The ODBC driver, as it's the only option (AFAIK) for connection to PostgreSQL via SpotFire Desktop. I could test my DB and the ODBC driver with razorsql, but it's just a vanilla PostgreSQL database on linux (freshly made), I recon someone has already done that for the realeased versions of the driver. I'm pretty sure it's a bug on the SpotFire side, but I wanted to doublecheck here before posting a ticket.
Link to comment
Share on other sites

  • 5 months later...
  • 1 month later...
  • 3 weeks later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...