Jump to content
We've recently updated our Privacy Statement, available here. ×

Script not getting executed upon document property change


S S 2

Recommended Posts

Hello,

I have made a data function(triggerOnFilter) which gets triggered when a filter(City) is changed. The Data function changes the value of document property(stores the count of the selected cities) but the script associated with it(Script) is not getting executed whenever the document property value is changing. The script is working fine with no errors when I run it manually. The script sets the zoom slider range for all graphs to its maximum size.

I have checked the box "Execute in Transaction" also in the script. For verification, I am displaying document property value for City Filter and toggle value for verification of execution of the script.

Does anybody faced a similar problem and have any idea what could be the reason for this discrepancy

 

Thanks in advance.

Link to comment
Share on other sites

Hi

Can you give a sequence of actions when this does not work

The data function changes the value of DocProperty to the number of cities selected. This works fine.

Whenever DocProperty changes, then the script is activated and the value if scriptest toggles between 1 and 2. This also seems to work, and the range appearsextended to its max.

The only case in which scriptest would not change value is when you select, say, a single city, then select another single city, as DocProperty would not change in this case.

Maybe I did not understandthe intended result.

Gaia

Link to comment
Share on other sites

  • 2 months later...
Hey, I am still having this issue with a similar script. How did you get this working Note, I ahve already verified that my document property for count is actually changing, but my script will not run. Am I possibly missing a step that allows my application to execute the script when the property changes. Note, the property is changing as intended, the script is attached to the property and the script is select to execute when the value changes. Also, there are no issues with the script, if I run it manually it works perfectly.
Link to comment
Share on other sites

  • 9 months later...
I had a similar issue where my script was working when I ran it manually, but for whatever reason, was not triggering properly.  The fix for me was just to save the visualization I was working on, then close the TIBCO Spotfire application and re-open it.  Reloading the form seemed to fix the issue since my script 'magically' started working fine.
Link to comment
Share on other sites

  • 1 month later...

I have to 2nd it that this is the "fix". 

 

I had the exact same issue where my script would work when run manually but would not get triggered when the linked property value changed.  But simply saving the visuallizaiton, closing Spotfire, then reopening and running the visulation resulted in everythign working as intended.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...