Jump to content

Why won't my data tables join

Christine Gopon

Recommended Posts

I am trying to join two data sets, using a unique identifier column.

The main datatable has 22541 rows and 52 columns. One of those columns is the identifier column.

The second datatable has 24,845 rows and 13 columns, including the identifier column. There are some additional rows here that I know will not match and be left out after the join.


The problem is that I cannot get the data to join. I've tried using the identifier, using other columns in common, trimming the identifier to make sure the were no extra spaces. Nothing. When I try to join, the new columns from the second dataset are never populated. Am I doing something wrong Is the size of the dataset an issue I'm at a bit of a loss here.

Link to comment
Share on other sites

Yes, they are both string datatypes. All identifiers are unique (i.e. no repeats). I've tried joining the data in so many different ways, and it just won't budge. I've been working with relatively large datasets for a while and I've always been able to join datatables with an identifier, so I am not sure what's amiss here. 
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...