Jump to content

Wrong object type 'symbol' in a call to 'CDR()' : dplyr packages

ta marketing

Recommended Posts

I want to use dplyr's %>% function.

Analyst's version was 10.10.3 LTS by applying a hot fix from 10.10.2,

It was confirmed that the TERR engine tool is also 6.0.0

TIBCO Enterprise Runtime for R version 6.0.0 for Microsoft Windows 64-bit


> x x%>%head(2)

Error in .Call() : Wrong object type 'symbol' in a call to 'CDR()'


But I still get these errors.

I checked to see if it was a problem with the package version of dplyr, but the same error occurred even then.

The current dplyr version is 0.8.5.


I need help!

Link to comment
Share on other sites

  • 2 months later...

Hello- I would try uninstalling and reinstalling dplyr using these steps below. the most current version of Dplyr is 1.0.7 and since you are using TERR 6.0, there is no need to use an earlier version of dplyr. 




Close all spotfire and TERR sessions. 


Open a new spotfire session and launch the TERR console. 


Type in the following:  remove.packages(.packages(all = TRUE, lib = .libPaths()[1]))




Also check out this similiar quesiton and answer: https://community.spotfire.com/questions/tidyverse-wrong-object-type-symbol-call-cdr 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...