Jump to content

Why can I not access any LiveView web application UIs on port 10080 any more

Steve Barber

Recommended Posts

What's going on here is likely that you are using the Google Chrome or Mozilla Firefox web browsers, and updated them recently. And new-ish versions of these browsers block access to port 10080 now by default. This is to help prevent increasingly common NAT Slipstreaming attacks from bad people who want to to bad things to your stuff.

Chrome, for example, shows an ERR_UNSAFE_PORT error on the browser frame now when an attempt is made to browse to port 10080 on any machine, including localhost.

I'd expect other browsers to follow suit soon enough.

How to you get around this issue It's probably safer to have your LiveView applications use a different LiveView Client Listen Port that isn't considered unsafe. You can set this port number by including a LiveView Client API Listener Configuration file in your LiveView fragment project and setting the configuration/ClientAPIListener/portNumber setting to a safeĀ® port number.

If you are willing to take the risk -- and I'm not not advising that you do so -- it is possible to have the browsers bypass the port restrictions. Again, I' not advising that you do this, but if you want to do it, it's a pretty easy web search for find out how for a given browser.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...