Jump to content

Python Data Function Extension: Temp file not found

Todd Cray

Recommended Posts

I've installed the Python Data Function Extension (1.3.1, but also tried 1.3 and 1.2.1 with same results)on SF 10.6. Using Python 3.7.9 and PIP'ed Pandas and NumPy, as required.

As a first test, I am trying to run the GroupBy.dxp sample that came with the Extension. This example takes two columns from an input file, performs three lines ofvery simple PY code and outputs a new data table with three columns. Instead of a result, I am getting an error message: File not found ...TemptmpA335.stdf (this file name changes as I re-run the PY Data Function):

Could not execute function call 'GroupBy'

File not found: C:UsersAdministratorAppDataLocalTemptmpA335.stdf

at Spotfire.Dxp.Data.Import.FileDataSource..ctor(String filePath, String[] additionalFilePaths)

at SpotfirePS.DataFunctions.Python.PythonDataFunctionExcecutor.d__4.MoveNext()

at Spotfire.Dxp.Application.Extension.CustomDataFunctionExecutor.d__5.MoveNext()

at Spotfire.Dxp.Data.DataFunctions.DataFunctionExecutorService.d__7.MoveNext()

When examining the Temp directory, I discover that an stdf file was created of the two columns from the input table. But just as the error suggests there is no stdf file by the name tmpA335.stdf. I assume that this one would have been the output from the PY code.

A while ago, a similar error was discussed here. In that case, the solution offered read: "The file not found error occurs whenever there is a mismatch between the parameters defined in Edit Script and those used in Edit Parameters.Checking required parameter is a handy safeguard for this."

However, this does NOT appear to be the problem here. For one thing, I am using--without any modifications--a TIBCO-provided sample that obviously worked before (as Ican see in the DXP, a proper output table had been generated on a previous run). For another, as I test with even simpler examples (such as: Using no input at all, output one single value to a Document Property) the same error keeps recuring.


I know that the Python Data Function Extension became obsolete with SF 10.7 native PY support. However, a migration at this time is not an option. Please help!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...