Jump to content

Spotfire not detecting Excel headers as name row

Kati Wu

Recommended Posts

I have been using a standard Excel template for my data and the headers are always the same. Sometimes when I try to import the file into Spotfire, SF cannot detect those header rows as the name row (instead as data row), with the column names automatically being "Column 1, Column 2, etc'...sometimes it detects perfectly.I have tried the following with no success:


Importing the data table from clipboard -- still the same result despite restricting data from the full sheet to just the table.

Changing the intended name row from "Data Row" to "Name Row" and refreshing -- instead this concatenates the name row with the "Column 1" header. Additional problem is thatnames are not imported whenthe column had been designated as a type other than string (i.e. if the majority of the colum is "real" then Spotfire leaves the name row blank since it isn't a real number)-- these names cannot be restored until you change all individual column data types first to string.

Adding my owntype row in the Excel sheet below the intended name row -- this worked occasionally to trick Spotfire into seeing my type row as a Type Row,which guided it to myname row above.

Changing the formatting of the name row in Excel.

Designating the header row in Excel via the printer dialogue.



Link to comment
Share on other sites

  • 3 weeks later...
  • 2 years later...
If you have any extraneous information beside your main table this can throw off Spotfire's ability to read in headers. Try cleaning up the data to just your main table with applicalbe column headers. For example: I had a Cutoff Date 6/1/21 in two cells on the header line of my table and this threw off the ability to load in the main table with headers.
Link to comment
Share on other sites

  • 3 years later...

Came across this thread while I was having similar issues. In this situation I have a section of excel columns containing primary descriptive data. This loaded fine. In the past week I added data across numerous additional columns. However, the original data had filters applied for sorting & filtering. The new columns were independent of those filters  - i.e. they wouldn't move and calculations would update as the other dataset was sorted and changed. I inserted a blank between these sections.

It seems the blank column was the issue. When I removed it, the headers were visible again.

  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...