Jump to content

Spotfire analyst error from python running sklearn - ImportError: No module named 'sklearn.__check_build._check_build'

Luke George

Recommended Posts

I recently upgraded my Spotfire environment to 11.4.4 and so needed to rebuild my python SPKs for Python Service and Spotfire Analyst. My requirements.txt document contains the sklearn module. When I deploy the created SPK for Spotfire Analyst and then run a python script that uses the sklearn module I get the following error:

Could not execute function call '#####'

Error executing Python script:

ImportError: No module named 'sklearn.__check_build._check_build'


Contents of C:Usersluke.georgeAppDataLocalTIBCOSpotfire11.4.4ModulesPython Packages_1.0.0.0site-packagessklearn__check_build:

setup.py         _check_build.cp37-win_amd64.pyd__init__.py



It seems that scikit-learn has not been built correctly.

If you have installed scikit-learn from source, please do not forget

to build the package before using it: run `python setup.py install` or

`make` in the source directory.

If you have used an installer, please check that it is suited for your

Python version, your operating system and your platform.

I did not have this error using the previous version of Spotfire and I have tried specifying the same module versions in the requirements.txt as used previously. Interestingly python scripts that run on the python node run without error.

Has anyone seen the same error before? Seems like some issue with building the SPK to me.

Link to comment
Share on other sites

Hello Luke,

As you mentioned that it works in the Python service/node, did you update that to use Spotfire Service for Python 1.3 when upgrading or is it still using an old version ? The 1.3 LTS python service versions - 1.3.7 is the latest - are the ones matched with Spotfire 11.4 LTS: https://docs.tibco.com/pub/spotfire/general/sr/sr/topics/spotfire_service_for_python_1_3.html

Your TIBCO Spotfire Analyst 11.4.4 comes with Python Interpreter 3.8.13 - if you hadn't updated the Python service, it's likely using an older Python Interpreter. 

So, I would start by verifying your versions, and if needed, update requirements.txt, re-build and deploy the package.  

For further troubleshooting, I recommend opening a support case in the Support portal - https://support.tibco.com. If you open a case, I recommend including your requirements.txt as well as a Debug log from your Analyst (enable debug logging, then reproduce the error). To enable Debug logging: in TIBCO Spotfire Analyst > Help menu > Support Diagnostics and Logging > Logging tab > change log level to DEBUG. 


Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...