Jump to content

Connecting from Spotfire Analyst to Spotfire Data Streams Minimal LiveView Sample fails: Unknown protocol

Sharad Honavar

Recommended Posts

Spotfire Analyst 11.4 and StreamBase Server 10.6

AS per a previous community question, which I tried, I could not get the same result (https://community.spotfire.com/questions/how-use-spotfire-data-streams-load-real-time-data-spotfire) I tried adding this comment to the thread with no success despite logging in with a support account.

I started the "sample_lv_sample_helloliveview_application.shonavar" in SB Studio which started the service on TCPport 61647. Also showed in the console and "epadmin display services" and "INFO com.streambase.sb.sbd.net.StreamBaseHTTPServer: sbd at DC1-SPTFR-PROD:8271; pid=288; version=10.6.1_0a0fdf7f8f3d4f25851d53e0e55c97ce2ece3d22; Listening".

In Spotfire Analyst I tried "Connect To -> New Connection" to "Tibco Spotfire Data Streams" and entered localhost:61647 for Server(also tried http://localhost:61647, (no authentication, TLS or compression), I got a Refused/Closed Connection from server in Spotfire Connect dialog. The Studio Console shows the follwing warning(s) for each attempt I tried.

"(fragment deploy): 2021-11-22 15:50:44.934000-0500 [9052:Thread- ThreadPool - 16] WARN com.streambase.sb.sbd.net.HTTPServer: Connection /0:0:0:0:0:0:0:1:58714: Unable to determine client protocol version"

On the host netstat, the Node in Studio is Listening on both IPV6 (and IP4) on 61647 and the Spotfire Analyst is trying on the IP4 and node expecting in IP6

Link to comment
Share on other sites

Hello shonavar,

The problem is that you are trying to use the StreamBase Client Listen Port rather than the LiveView Client Listen Port.

You need to use the LiveView Client Listen Port


For example:


epadmin display services




Network Address = dtm-dist://IPv4:SBARBER-T480:24599

Service Name = liveview.liveview0.sample_lv_sample_lvweb.sbarber

Service Type = liveview

Network Address = sb://SBARBER-T480:16185 lv://SBARBER-T480:10080


The lv: URI there has the LiveView Client Listen Port, which in this case is 10080.


(BTW it is no longer a good idea to use 10080 as most browsers now block it for security reasons. As of Streaming/Spotfire Data Streams 10.6.1, 10080 was still the default, so it may have to be set in the configuration to avoid it. See https://community.spotfire.com/questions/why-can-i-not-access-any-liveview-web-application-uis-port-10080-any-more for details.)

Also you can see the LiveView Client Listen Port in the engine log in a line that looks like this:


(fragment deploy): 2021-11-23 13:11:45.326000-0500 [68728:JettyService] INFO com.streambase.liveview.server.dtmmarket.DTMarket: We are configured to be on lv://SBARBER-T480:10080/

Link to comment
Share on other sites

Also, with regard to your statement in the Question:


"I tried adding this comment to the thread with no success despite logging in with a support account"


Two things to mention there:


1) "logging in with a support account"


Accounts for TIBCO Community and TIBCO Support are separate accounts. Having a support account doesn't get you rights on Community and vice versa. Though that wasn't actually why you couldn't add a comment.2) "I tried adding this comment to the thread" on another Community Answer article from 2019.


Right, the ability to add comments to a Community Answer article expires after a while.In this case, it's great that you made a new Answer post, because the problem you encountered and wanted to ask about -- in essence, how to I determine what LiveView Client Listen Port my LiveView engine process is using -- is somewhat separate from the issue addressed in the 2019 article anyway. In general, Community is more useful when it has lots of short Answer posts rather than fewer, longer posts. That is, each post should really be focused on as small an issue as possible.That said, I went ahead and updated the 2019 article to indicate that you need to know the LiveView Client Listen Port, and that it might not be 10080, and how to find out what it is! (by referencing this post). So thanks, that's an improvement!

Link to comment
Share on other sites

Thank you very much sbarber. really helped to clue me in. I was running it as EventFlow frag(the default using the undropped Run button ). Ran as LiveView frag in Run As Config and saw the lv servicetype and Spotfire then connected to live tables at the address.


By the way what doc is the Run As->Create-Manage-Run Configuration screen parameters explained in  Shows all the projects in workspace and little confusing.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...