Jump to content

Spotfire Automation from Client, TryGetTool fails

Pratibha Gaglani

Recommended Posts

I have setup Spotfire Automation, where in I try to call in a Data Source Tool from a client application. When my clientDLL.dll and DataSourceToolDLL.dll versions match up, this works correctlly.


I have now changed the version of one of them, and TryGetTool fails.


I have tried to set the version compatibility in the pkgdesc as follows: I was hoping if the client is at 21.1 version, this should work for me.





Can you guide me as to where I am going wrong

Link to comment
Share on other sites

Hi Prathiba,


I am not an expert on the xml tag part. I can only see it worked fine in the original setup, when you had the same versions of both dll files. The link broke as soon as you worked with different versions of the dll files (even though you set the xml tag).


I would suggest to go back to the original situation and have the same versions of both dll files (if possible). If not possible, I would suggest you create a suport case and see if support can help you further.


Kind regards,



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...